[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Handle-info] Problems building Client Library (ver. 5) -- C Version


I've downloaded the Client Library (ver. 5) -- C Version and tried to
build it on my PC but I wasn't able to.  I've had the errors described

Any help would be much appreciated.

I'm using a Dell T3400 running OpenSuse Linux #1
SMP 2010-02-22 16:49:47 +0100 x86_64 x86_64 x86_64 GNU/Linux

hdl_crypto.c:52: error: static declaration of 'x' follows non-static

   Changed `static int x = 0;' to `static int xx = 0;'
   and lines 267-268 accordingly:

   void AddX(){xx++;};
   int getX() {return xx;}

Next error:

Running Mkbootstrap for hdllib ()
chmod 644 hdllib.bs
rm -f blib/arch/auto/hdllib/hdllib.so
LD_RUN_PATH="/usr/lib64" cc  -shared -L/usr/local/lib64 ../hslookup.o
perl_hdl_wrap.o  -o blib/arch/auto/hdllib/hdllib.so 	\
	   -L/home/lfinsto/hcc5/perl/../.libs -lhdl -lcrypto  	\

../hslookup.o: relocation R_X86_64_32 against `a local symbol' can not be
used when making a shared object; recompile with -fPIC
../hslookup.o: could not read symbols: Bad value
collect2: ld returned 1 exit status

I've never used libtool, so I don't know how to fix this.

In `hcc5/Makefile.am' there's a commented-out line:

#AM_CFLAGS=-Wall -fpcc-struct-return -fPIC

I tried inserting


Then I ran

aclocal && autoconf && autoheader && automake && configure

When I tried to run `make' it blocked at this point:

/bin/sh ./libtool --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H -I.     -g
-MT hdl_admin.lo -MD -MP -MF .deps/hdl_admin.Tpo -c -o hdl_admin.lo

and lots of processes running libtool and sed were created:

2417 pts/2    S+     0:00 /usr/bin/sed s%^.*/%%
 2418 pts/2    S+     0:00 /bin/sh ./libtool --no-reexec
 2419 pts/2    S+     0:00 /bin/sh ./libtool --no-reexec
 2421 pts/2    S+     0:00 /usr/bin/sed s%^.*/%%
 2423 pts/2    S+     0:00 /bin/sh ./libtool --no-reexec
 2424 pts/2    S+     0:00 /bin/sh ./libtool --no-reexec
 2425 pts/2    S+     0:00 /usr/bin/sed s%^.*/%%
 2428 pts/2    S+     0:00 /bin/sh ./libtool --no-reexec
 2429 pts/2    S+     0:00 /bin/sh ./libtool --no-reexec
 2431 pts/2    S+     0:00 /usr/bin/sed s%^.*/%%
 2433 pts/2    S+     0:00 /bin/sh ./libtool --no-reexec
 2434 pts/2    S+     0:00 /bin/sh ./libtool --no-reexec
 2435 pts/2    S+     0:00 /usr/bin/sed s%^.*/%%
 2438 pts/2    S+     0:00 /bin/sh ./libtool --no-reexec
 2439 pts/2    S+     0:00 /bin/sh ./libtool --no-reexec
 2440 pts/2    S+     0:00 /usr/bin/sed s%^.*/%%
 2443 pts/2    S+     0:00 /bin/sh ./libtool --no-reexec
 2444 pts/2    S+     0:00 /bin/sh ./libtool --no-reexec
 2447 pts/2    S+     0:00 /usr/bin/sed s%^.*/%%
 2448 pts/2    S+     0:00 /bin/sh ./libtool --no-reexec
 2449 pts/2    S+     0:00 /bin/sh ./libtool --no-reexec


They kept being created until I killed the shell from which I started `make'.

I also tried it with the whole line:

AM_CFLAGS=-Wall -fpcc-struct-return -fPIC

with the same result.

The same thing also happened when I tried this:

In ~/hcc5/perl/Makefile.PL.in:


   'INC' => '-I@top_srcdir@/ @CFLAGS@',


   'INC' => '-I@top_srcdir@/ @CFLAGS@ -fPIC',

It immediately blocked at the same point after I tried `make clean', which
would seem to indicate that generated files weren't being deleted.  However,
there weren't any `.o' files in /hcc5/ or below.  I got an error when I
tried `make maintainer-clean'.

I noticed that the latest timestamp on the `.c' and `.h' files was from
2006.  Is the C library being actively maintained and developed?


Laurence Finston

Laurence Finston
Gesellschaft fuer wissenschaftliche Datenverarbeitung mbH
Am Fassberg 11
37077 Goettingen

Telefon: 	+49 551 201-1882
E-Mail: 	lfinsto@gwdg.de

Handle-Info mailing list